domingo, mayo 03, 2009

Compilando Inkscape 0.47 SVN en Jaunty.

Hace un tiempo atrás había escrito un post de como instalar Inkscape 0.47 en su versión SVN pero con información muy básica y casi nada sobre las dependencias necesarias para poder compilar esta versión. Es por eso que he escrito un nuevo post relacionado a la instalación de Inkscape versión de desarrollo en Ubuntu Jaunty 9.04.
Se publican los errores para que sirvan de referencia de que paquetes se están instalando.

Código para la instalación:

$ svn co https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk inkscape
$ cd inkscape
$ ./autogen.sh
Bueno lo primero es instalar los paquetes fundamentales para poder compilar


$ sudo apt-get install autoconf automake autotools-dev intltool libglib2.0-dev m4


$ ./configure

configure: error: libpng >= 1.2 is needed to compile inkscape



$ sudo apt-get install libpng12-dev zlib1g-dev

$ ./configure
configure: error: libgc (the Boehm Conservative Collector) 6.4+, is needed to compile inkscape -- http://www.hpl.hp.com/personal/Hans_Boehm/gc


$ sudo apt-get install libgc-dev

$ ./configure

configure: error: Cannot find freetype-config


$ sudo apt-get install libfreetype6-dev libice-dev libkpathsea-dev libpthread-stubs0 libpthread-stubs0-dev libsm-dev libt1-dev libt1-doc libx11-dev libxau-dev libxaw7-dev libxcb1-dev libxdmcp-dev libxext-dev libxmu-dev libxmu-headers libxpm-dev libxt-dev vflib3 vflib3-dev x11proto-core-dev x11proto-input-dev x11proto-kb-dev x11proto-xext-dev xtrans-dev

$ ./configure
configure: error: --enable-lcms was specified, but appropriate LittleCms development packages could not be found


$ sudo apt-get install python-liblcms liblcms1-dev

$ ./configure
checking for INKSCAPE... configure: error: Package requirements (gdkmm-2.4 glibmm-2.4 gtkmm-2.4 >= 2.10.0 gtk+-2.0 libxml-2.0 >= 2.6.11 libxslt >= 1.0.15 cairo sigc++-2.0 >= 2.0.12 gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met


$ sudo apt-get install libatk1.0-dev libcairo2-dev libcairomm-1.0-dev libdirectfb-dev libdirectfb-extra libexpat1-dev libfontconfig1-dev libglibmm-2.4-dev libgtk2.0-dev libgtkmm-2.4-dev libjpeg62-dev libpango1.0-dev libpangomm-1.4-dev libpixman-1-dev libsigc++-2.0-dev libsysfs-dev libxcb-render-util0-dev libxcb-render0-dev libxcomposite-dev libxcursor-dev libxdamage-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev libxrandr-dev libxrender-dev
x11proto-composite-dev x11proto-damage-dev x11proto-fixes-dev x11proto-randr-dev x11proto-render-dev x11proto-xinerama-dev libgsl0-dev libxml++2.6-dev libxml2-dev libxslt1-dev

$ ./configure
configure: error: You need the boost package (e.g. libboost-dev)


$ sudo apt-get install gccxml libboost-date-time1.35-dev libboost-date-time1.35.0 libboost-filesystem1.35-dev libboost-filesystem1.35.0
libboost-graph1.35-dev libboost-graph1.35.0 libboost-iostreams1.35-dev libboost-iostreams1.35.0 libboost-program-options1.35-dev
libboost-program-options1.35.0 libboost-python1.35-dev libboost-python1.35.0 libboost-regex1.35-dev libboost-regex1.35.0 libboost-serialization1.35-dev
libboost-serialization1.35.0 libboost-signals1.35-dev libboost-signals1.35.0 libboost-system1.35-dev libboost-system1.35.0 libboost-test1.35-dev
libboost-test1.35.0 libboost-thread1.35-dev libboost-thread1.35.0 libboost-wave1.35-dev libboost-wave1.35.0 libboost1.35-dev libboost1.35-doc
libicu-dev python-dev python2.6-dev

$ ./configure
configure: error: libpopt is required


$ sudo apt-get install libpopt-dev

$ ./configure
$ make
$ sudo make install
$ inkscape
Paciencia.. la compilación puede durar varios minutos.

Hay que mencionar que antes de instalar la version SVN se había instalado la versión Estable por lo que pueden variar ciertas dependencias.